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ABSTRAK

Burung walet merupakan ternak unggas yang dibudidayakan dengan sarang
sebagai produksi utama. Umumya burung wallet menyenangi tempat yang bersuhu hangat
sebagai tempat tinggalnya untuk membuat sarang, selain itu keadaan suhu dan kelembaban
udara yang stabil dapat menghasilkan sarang burung walet yang berkualitas sehingga
memiliki harga jual yang tinggi. Oleh sebab itu penerangan yang mirip dengan gua-gua
alami yang remang-remang maupun gelap pada umumnya sangat disukai oleh burung walet
untuk dijadikan sebagai sarang, sehingga peternak walet biasanya menggunakan berbagai
media untuk membuat ruangan jadi gelap, seperti menggunakan cat dinding warna
hitam, namun hal ini tidak disukai oleh burung walet karena umumnya sangat sensitif
terhadap bau yang pekat sehingga hanya akan membuat burung walet tidak tinggal di
dalam ruangan tersebut. Rancangan sistem pengendali suhu kelembaban dan cahaya pada
rumah walet berbasis mikrokontroller ini dirancang dengan tujuan untuk mempermudah
peternak melakukan pengontrolan secara berkala. Hasil penelitian ini diharapkan dapat
memberikan keriganan bagi para peternak sehingga mereka tidak terlalu banyak membuang
waktu untuk mengurus rumah walet.

Kata kunci : Suhu dan Kelembaban, Cahaya, rumah wallet

ABSTRACT

Swallows are poultry farmed with nests as the main production. Generally, the bird
wallet likes warm temperatures as a place to live to make a nest, besides that a stable
temperature and humidity can produce high quality swallow nests so that it has a high selling
price. Therefore lighting that is similar to natural caves that are dim or dark in general is very
preferred by swallow birds as a nest, so swallow breeders usually use various media to make
the room dark, such as using black wall paint, but this is not liked by swifts because generally it
is very sensitive to thick odor so that it will only make the swallow not live in the room. The
design of humidity and light temperature control systems in microcontroller-based swallow
houses is designed with the aim of making it easier for breeders to carry out regular control.
The results of this study are expected to provide relief for farmers so that they do not waste too
much time managing the swallow's house.

Keywords: Temperature and Humidity, Light, home wallet

1. PENDAHULUAN

Burung walet merupakan ternak unggas yang dibudidayakan dengan sarang sebagai
produksi utama. Burung wallet memiliki beberapa cirri khas yang tidak dimiliki oleh burung
lain. Ciri khas tersebut diantaranya melakukan hamper segala aktivitasnya di udara seperti
makan dan bereproduksi, sehingga burung wallet sering disebut dengan burung layang-
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layang. Burung walet merupakan burung pemakan serangga yang bersifat aerial dan suka
meluncur. Burung ini berwarna gelap, terbangnya cepat dengan ukuran tubuh sedang atau
kecil, dan memiliki sayap berbentuk sabit yang sempit dan runcing, kakinya sangat kecil begitu
juga paruhnya dan jenis burung ini tidak pernah hinggap di pohon. Selain itu, cirri yang paling
khas dari jenis burung ini yaitu kemampuannya dalam menghasilkan sarang yang bernilai jual
tinggi.
Terdapat beberapa jenis burung wallet yang ditemukan di Indonesia, salah satunya adalah
Collocalia fuciphaga, spesies ini merupakan burung wallet yang mampu menghasilkan sarang
berwarna putih dan paling disukai konsumen. Burung wallet (Collocalia fuciphaga) tersebar
diberbagai pulau. Umumya burung wallet menyenangi tempat yang bersuhu hangat sebagai
tempat tinggalnya untuk membuat sarang, selain itu keadaan suhu dan kelembaban
udara yang stabil dapat menghasilkan sarang burung walet yang berkualitas sehingga
memiliki harga jual yang tinggi . Penerangan yang mirip dengan gua-gua alami yang
remang-remang maupun gelap pada umumnya sangat disukai oleh burung walet untuk
dijadikan sebagai sarang, sehingga peternak walet biasanya menggunakan berbagai media
untuk membuat ruangan jadi gelap, seperti menggunakan cat dinding warna hitam, namun hal
ini tidak disukai oleh burung walet karena umumnya sangat sensitif terhadap bau yang
pekat sehingga hanya akan membuat burung walet tidak tinggal di dalam ruangan tersebut [1]

1.1. Penelitian Terkait

Gedung untuk rumah walet harus memiliki suhu, kelembaban yang stabil Oleh karena
itu, biasanya peternak harus melakukan pengukuran suhu dan kelembaban yang dilakukan
dengan menggunakan thermometer dan hygrometer3-4 kali seminggu untuk mengetahui
apakah suhu dan kelembabannya sesuai. Suhu gua alami yang berkisar antara 26-28˚C dan
kelembaban ± 80-90 %[2]. Intensitas cahaya yang disukai oleh burung wallet untuk bersarang
adalah 0 lux (gelaptotal) atau 0,2 – 0,5 foot candle (fc) yang setara dengan 2 nyala lilin.[3]

1.2. Karakteristik Suhu Ruangan
Di lapisan udara selalu terdapat uap air. Kadar uap air yang terdapat di udara disebut juga

kelembaban atau kelengasan udara. Kelembaban udara dapat diartikan banyaknya kandungan uap air
dalam massa udara. Kelembaban udara dapat dihitung dengan menggunakan alat hygrometer.
Kelembaban udarah menggambarkan kandungan uap air diudara yang dapat dinyatakan sebagai
kelembaban mutlak (relatif) maupun definisi tekanan uap air kelembaban mutlak adalah kandungan uap
air per satuan volume [4]. Kelembaban udara dibedakan atas kelembaban mutlak (absolut) dan
kelembaban relatif.
1) Kelembaban Mutlak (Absolut)

Kelembaban mutlak atau kelembaban absolut adalah jumlah massa uap air per satuan volume udara.

Kelembaban mutlak dinyatakan dalam gram/m
3

. Kelembaban mutlak menyatakan kelembaban aktual
yang pada saat tertnetu benar-benar terjadi. Kelembaban mutlak jarang digunakan dalam perhitungan
karena dapat berrubah-ubah akibat adanya perubahan suhu udara.

2) Kelembaban Relatif (Nisbi)
Kelembaban relatif adalah perbandingan jumlah uap air yang terkandung di udara (kelembaban
mutlak/absolut) dengan jumlah uap air maksimal (jenuh) di dalam udara pada temperatur dan tekanan
udara yang sama. Kelembaban relatif dinyatakan dalam persen.

1.2 LDR

LDR adalah suatu bentuk komponen yang mempunyai perubahan resistansi yang
besarnya tergantung pada cahaya. Karak teristik LDR terdiri dari dua macam yaitu Laju
Recovery dan Respon Spektral[5]
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1. Laju Recovery
Bila sebuah LDR dibawa dari suatu ruangan dengan level kekuatan cahaya tertentu ke

dalam suatu ruangan yang gelap, maka bisa kita amati bahwa nilai resistansi dari LDR tidak
akan segera berubah resistansinya pada keadaan ruangan gelap tersebut. Na-mun LDR tersebut
hanya akan bisa menca-pai harga di kegelapan setelah mengalami selang waktu tertentu. Laju
recovery meru-pakan suatu ukuran praktis dan suatu ke-naikan nilai resistansi dalam waktu
tertentu.

2. Respon Spektral
LDR tidak mempunyai sensitivitas yang sama untuk setiap panjang gelombang cahaya

yang jatuh padanya (yaitu warna). Bahan yang biasa digunakan sebagai penghantar arus listrik
yaitu tembaga, aluminium, baja, emas dan perak. Dari kelima bahan tersebut tembaga
merupakan penghantar yang paling banyak, digunakan karena mempunyai daya hantaryang
baik (TEDC,1998)

1.5. Relay

Relay adalah saklar (switch) elektrik yang bekerja berdasarkan medan magnet.
Relay terdiri dari suatu lilitan dan switch mekanik.[5] Switch mekanik akan bekerja jika ada
arus listrik yang mengalir melalui lilitan. Susunan kontak pada relay adalah:

Normally Open : Relay akan menutup bila dialiri arus listrik.
Normally Close : Relay akan membuka bila dialiri arus listrik.
Changeover : Relay ini memiliki kontak tengah yang akan melepaskan diri

dan membuat kontak lainnya berhubungan.

Gambar 1. Relay

2. METODE PENELITIAN

Proses penelitian dan perancangan system ini dilaksanakan sejak minggu kedua bulan
Juni 2018 sampai minggu keempat bulan september 2018. Untuk melakukan analisa dan
mendapatkan data berdasarkan latar belakang masalah yang diajukan maka penulis melakukan
penelitian pada Lab Mikrokontroller STMIK Dipanegara Makassar.

2.1. Alat dan Bahan
a. Arduino Uno R3 Atmega328
b. LCD 16 x 2
c. Gear Micro Servo Motor Tower Pro SG90
d. Relay 2 Chanel dan 1 Chanel 5 Volt
e. Sensor DHT11
f. Element (Heater) 220 volt
g. FAN Power Supply Happy
h. Penyemprot 12 volt dan Gorden [6], [7], [8]
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3. HASIL DAN PEMBAHASAN

3.1 Rancangan System
Adapun rancangan sistem yang akan dibangun dapat dilihat pada gambarsebagai berikut:

Gambar 2 Diagram Blok

Gambar 3 Rancangan Sistem

Alat Prototipe ini dibangun menggunakan mikrokontroller Arduino dengan
menggunakan sensor pengukur kelembaban RH (Relative Humidity). Alat ini dibuat untuk
mengetahui kelembaban uap air yang ada pada rumah wallet. System utama pada control
kelembaban ini diatur oleh mikrokontroller. Input mikrokontroller ini diperoleh dari sensor
kelembaban untuk mendapatkan nilai kelembaban. Data dari sensor tersebut akan ditampilkan
nilainya pada LCD. Tujuan dari pemasangan Heater (pemanas) adalah agar keadaan
temperature dalam rumah walet bersifat homogen (merata) sehingga pemanasan akan sama
pada semua daerah. Dengan memanfaatkan Fan / kipas yang berguna untuk menyebarkan
panas sehingga keadaan suhu rumah wallet merata (homogen) sedangkan fungsi dari
pemesangan spray adalah guna untuk menyemprot runagan apabila ruangan melebihi suhu
290 C. Penggunaan realay yang terhubung ke heater berfungsi untuk memacu agar pada
saat sensor suhu kelembaban terpenuhi maka heater akan bekerja, penggunaan relay terhubung
ke spray berfungsi untuk memacu agar sensor suhu kelembaban terpenuhi maka spray akan
berfungsi sedangkan relay yang terhubung ke fan/kipas sama fungsinya dengan yang terhubung
ke heater dan spray. LDR berfungsi untuk mengatur cahaya pada rumah wallet agar
cahaya yang masuk pada rumah wallet tidak berlebihan dengan memanfaatkan motor servo
sebagai pengontrol buka dan tutup tirai berwarna hitam apabila cahaya yang masuk lebih
kecil dari 0.5 fc maka tirai akan terbukan dan apabila cahaya lebih dari 0.5 fc maka tirai akan
tertutup.

3.2 Perancangan dan Pengujian Alat
Dalam implementasi perancangan alat ini terdiri dari rangkaian minimum

mikrokontroler, sensor cahaya, sensor suhu kelembaban yang berfungsi sebagai pemicu dari
mendeteksi jika terjadi perubahan suhu ruangan dan nilai cahaya yang masuk pada ruangan.
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Gambar 4 Tampak Atas

Ket:
1. Arduino Uno R3 Atmega328
2. LCD 16 x 2
3. Gear Micro Servo Motor Tower Pro SG90
4. Relay 2 Chanel dan 1 Chanel 5 Volt
5. Sensor DHT11
6. Element (Heater) 220 volt
7. FAN Power Supply Happy
8. Penyemprot 12 volt
9. Gorden

Gambar 5 Tampak Depan

Ket
1. LCD 16x2, 2. Gorden Keterangan pada LCD, 3. S= Nilai Suhu
4. K= Nilai Kelembaban, 5. Cahaya= Nilai Cahaya

3.3 Perancangan Konstruksi Rumah Walet
Sebelum kami membuat Bagunan Sistem Pengendali Suhu Kelembaban dan Cahaya

Pada Rumah Walet ini terlebih dahulu kami membuat gambaran desain agar nantinya
mempermudah kami dalam membuat bentuk aslinya, ada pun software yang kami gunakan
adalah coreldraw X4, berikut konstruksi keseluruhan:
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Gambar 6 Desain Bagunan

3.4 Perancangan Perangkat Keras

Berdasarkan perancangan alat Bagunan Sistem Pengendali Suhu Kelembaban dan
Cahaya Pada Rumah Walet Berbasis Mikrokontroller, maka dibawah ini dijelaskan
perancangan perangkat keras untuk sistem ini. Pada perancangan desain Bangunan sisntem
kendali suhu kelembaban dan cahaya ini menggunakan sensor DHT11 untuk suhu dan
kelembaban dan Sensor LDR untuk cahaya.

3.5 Perancangan Perangakat Lunak
Pemilihan software IDE Arduino didalam perancangan perangkat lunak ini karena

kemudahan proses coding yang dapat mempermudah dalam penulisan program sebab
telahtersedia library sebagai acuan dalam proses coding, serta settingan yang mudah pada
saat program akan diupload pada perangkat kerasnya. Dengan model teknisnya sebagai berikut
a. Program yang telah dibuat pada software IDE Arduinoakan tersimpan dengan ekstensi

arduino file.
b. Proses kompailer akan dilakukan langsung setelah file telah tersimpan dan dapat dilihat

apakah terjadi pesan error/tidak.
c. Sebelum proses upload, terlebih dahulu periksa COM dan tipe Modul Arduino yang sesuai.
d. Dengan demikian program yang telah dibuat dan diuploaddapat diuji cobakan dengan

melihat gerakan-gerakan robot.

3.6 Prinsip Kerja Alat
Pada saat pengguna menyambung daya listrik, saklar ON/OFF ditekan maka daya

akan terhubung ke arduino. Didalam arduino ada komponen IC L7805 yang berfunsi untuk
menurunkan tegangan dari 12V dari adaptor menjadi 5V. karena tegangan yang di butuhkan
oleh LCD, DHT11, sensor LDR, Motor Servo dan Relay adalah 5V sehingga pengguna
dapat mengambil tegangan 5V dari arduino uno R3 Atmega 328 guna untuk memberikan
supply tegangan ke LCD, DHT11, sensor LDR, Motor Servo dan relay, maka secara otomatis
alat akan bekerja LCD akan menampilkan data suhu kelembaban dan cahaya yang dideteksi
oleh sensor DHT11 dan sensor LDR pada saat sensor mendeteksi suhu rendah maka secara
otomatis relay akan aktif untuk menyambungkan daya ke heater dan FAN, sehingga heater
akan menghasilkan panas yang akan di bantu oleh kipas untuk menyebarkan panasnya ke
seluruh ruangan untuk menormalkan kembali suhu, dan apabila suhu dalam ruangan tinggi
maka relay akan aktif untuk menyambungkan daya ke penyemprot/spray, sehingga
penyemprot akan aktif untuk menyiram ruangan agar suhunya normal kembali. Apabila
cahaya dalam ruangan melebihi 0.5 FC maka tirai akan tertutup yang digerakkan oleh
motor servo. Apabila cahaya dalam runagan kurang 0.5 FC maka tirai akan terbuka begitulah
secara otomatis terus menerus.
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Gambar 7 Skematik Rangkaian Perancangan Alat

3.7 Pengujian Perangkat keras
Perangkat keras sebelum digunakan dalam sistem, maka terlebih dahulu dilakukan

tahap-tahap pengujian alat dan rangkaian. Tujuan pengujian perangkat keras adalah untuk
mengetahui ketepatan dan ketelitian dari perangkat keras yang kita buat, sehingga dengan
melakukan pengujian secara bertahap pada masing- masing rangkaian akan diketahui
kekuranganyang mungkin bisa untuk lebih diperbaiki lagi, meski ada beberapa alat yang sulit
untuk dicoba perbagian dikarenakan terbatasnya peralatan. Adapun pengujian yang
dilakukan dengan menggunakan system pengujian black box sebagaimana yang telah
dijelaskan pada bab sebelumnya. Dan pengujian Perangkat keras sebelum digunakan dalam
sistem, maka terlebih dahulu dilakukan tahap-tahap pengujian alat dan rangkaian. Adapun
tujuan pengujian perangakat keras yang akan kita gunakan ialah untuk mengetahui apakah
modul yang akan digunakan dapat berfungsi dengan baik atau tidak sehingga tidak
menghambat kita dalam pembuatan alat.

3.8 Pengujian Modul Arduino Uno R3 Atmega328
Untuk memastikan Arduino telah terpasang dengan benar dan dapat

berkomuniasi dengan interaktif maka ia perlu diuji.
1. Jalankan IDE Arduino dengan menjalankan file arduino.exe pada software Arduino.

Gambar 8 Aplikasi IDE Arduino

2. Jalankan menu Tools→Board kemudian pilih tipe papan yang sesuai.

Gambar 9 Pemilihan Jenis Board Arduino
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3. Jalankan menu File→Examples→1.Basic→Blink. Ini adalah program sederhana
yang fungsinya adalah membuat lampu LED menyala berkedip- kedip.

Gambar 10 Pemilihan Contoh Program

Gambar 11 Contoh Program LED

Bagian itu adalah perintah untuk menunda aliran program selama satu detik (1000 mili
detik).Jadi bila lampu LED diperintahkan menyala pada baris sebelumnya, maka dengan
perintah delay () lampu itu akan bertahan menyala selama satu detik sebelum ia diperintahkan
untuk padam pada baris berikutnya. Mangubah ke dua angka 1000 itu menjadi 200 agar
interval nyala-padam menjadi lebih pendek. Pada toolbar klik tombol Upload untuk memuat
sketch tersebut kedalam papan Arduino.

Gambar 12 Tombol Upload Program

Jika Anda cukup beruntung maka sketch akan dimuat, ditandai dengan
pesan berhasil seperti di bawah ini.

Gambar 13 Pesan Tanda Berhasil Upload Program

Namun jika kurang beruntung (seperti pada kebanyakan kasus umumnya) maka akan
muncul pesan kesalahan seperti berikut.

Gambar 14 Pesan Tanda Gagal Upload Program



JURNAL SISTEM INFORMASI DAN TEKNOLOGI INFORMASI: 1978-1520 

Vol. 8, No. 2, Oktober 2019

139

Solusinya cukup mudah, yaitu cukup mengganti pilihan serial port melalui menu
Tools→Serial Port. Jika Anda tidak yakin pada port nomor berapa papan Arduino itu
terhubung, coba pilih sebuah nomor port lalu jalankan upload sepertilangkah sebelumnya.
Jika pesan kesalahan masih muncul, ganti nomor port-nya dan lakukan berulang-ulang
ampai upload berhasil.

Gambar 15 Pemilihan COM

3.9 Uji BlackBox

Tabel 1 Tabel Pengujian

No Pengujian Hasil yang diharapkan Keterangan

1 On Power Supply

Alat akan menyala LCD
akan menampilkan nilai
suhu kelembaban dan
nilai cahaya

sesuai

2
Suhu < 260C kelembaban < 65
RH Heater dan kipas aktif sesuai

3
Suhu > 290 C kelembaban > 95
RH Penyemprot aktif sesuai

4 Cahaya > 0.5 fc Tirai tertutup sesuai

5 Cahaya < 0.5 fc Tirai terbuka sesuai

4. KESIMPULAN

Dari seluruh proses pengerjaan tugas akhir ini mulai dari pengerjaan penulisan sampai
ke pengerjaan sistemnya, penulis dapat menarik beberapa kesimpulan, yaitu:
1. Alat yang telah dirancang dapat mengenandalikan suhu, kelembaban dan cahaya dalam

ruangan (rumah walet).
2. Hasil pengujian alat menunjukkan sensor LDR bekerja pada intensitas cahaya 0.5 fc

dan sensor DHT11 bekerja pada suhu 26- 29 ˚C dan kelembaban 65-95 RH
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